Having trouble with mChat lately

Support for mods released by phpbbmodders.net found at either https://github.com/phpbbmodders/ or the MODDB at http://www.phpbb.com
Forum rules
Please only request support for mods released by phpbbmodders.net found at either https://github.com/phpbbmodders/ or the MODDB at http://www.phpbb.com
Mike86
New member
New member
Posts: 6
Joined: 21 Dec 2014, 08:13

Re: Having trouble with mChat lately

Postby Mike86 » 21 Dec 2014, 13:40

1.3.5

User avatar
RMcGirr83
Past Contributor
Past Contributor
Posts: 6243
Joined: 30 Nov 2006, 14:23
Real name: Rich McGirr

Re: Having trouble with mChat lately

Postby RMcGirr83 » 21 Dec 2014, 13:45

Many free hosts will not allow an ajax based chat as it may overload other accounts on the same server.

tenkai
New member
New member
Posts: 3
Joined: 24 Dec 2014, 18:18

Re: Having trouble with mChat lately

Postby tenkai » 24 Dec 2014, 18:31

I'm having a similar issue, except I don't even have an editor.js file to edit in the version of prosilver I'm using.

To recap, the Send, Reset, Smilies and BBCodes buttons do not work. Purge does, though.

User avatar
Sniper_E
MOD Team
MOD Team
Posts: 591
Joined: 13 Jun 2011, 16:53
Location: Shreveport, LA

Re: Having trouble with mChat lately

Postby Sniper_E » 25 Dec 2014, 17:57

The editor.js edit is for the input box in mchat.
The .js file edits in the overall_header,html is for the drop down smilies, bbcodes and scroll.

Check your overall_header and make sure the .js files needed to load are in the right place.
Check in the prosilver/template/ directory for the editor.js file for those edits. Your style may inherit that file from prosilver.
No is NEVER an Option and NEVER is the only Option when it comes to Giving Up!

tenkai
New member
New member
Posts: 3
Joined: 24 Dec 2014, 18:18

Re: Having trouble with mChat lately

Postby tenkai » 26 Dec 2014, 13:52

Uninstalling mChat and reinstalling it appeared to do the trick as far as posting is concerned. Didn't fix the issue for the smilies and bbcodes, obviously, as I don't have the js files necessary to allow those to function properly.
I checked the newest build of PHPBB (3.1.2) for the editor.js file in the prosilver template, but it doesn't appear to be there. Any ideas where I can grab this? Will it even help if they aren't using it in the current build?

User avatar
RMcGirr83
Past Contributor
Past Contributor
Posts: 6243
Joined: 30 Nov 2006, 14:23
Real name: Rich McGirr

Re: Having trouble with mChat lately

Postby RMcGirr83 » 26 Dec 2014, 14:21

This mod hasn't been updated for 3.1.2 and it is odd that prosilver no longer has editor.js within it as there is this line within posting_buttons.html file

<script type="text/javascript" src="{T_SUPER_TEMPLATE_PATH}/editor.js"></script>

However, saying that the editor.js file can be found within the assets/javascript directory in 3.1.2

tenkai
New member
New member
Posts: 3
Joined: 24 Dec 2014, 18:18

Re: Having trouble with mChat lately

Postby tenkai » 26 Dec 2014, 14:30

NBD. I removed the Smilies and BBCodes buttons from the post area for now. Most people know how to write out the code by now anyway.

Thanks!

User avatar
RMcGirr83
Past Contributor
Past Contributor
Posts: 6243
Joined: 30 Nov 2006, 14:23
Real name: Rich McGirr

Re: Having trouble with mChat lately

Postby RMcGirr83 » 26 Dec 2014, 14:38

I edited my post above.


Return to “Modders MOD support”

Who is online

Users browsing this forum: CommonCrawl [Bot] and 5 guests